MTD Module update

We are making all our customers and users of the Sage X3 MTD for VAT module aware of a change happening soon. On 22 May Sage are updating the MTD for VAT module.

This affects customers on Sage X3 V6 to V11 using the MTD add-in.

This update contains important security changes to the embedded browser, which is used to complete the authentication and submission to HMRC. The module is used by a number of products in the Sage range.

The first time you open the module after 22 May you will be prompted to download and install a small update. The update needs to be performed on all PCs on which the module is installed.

All PCs need .net version 4.7.2 or higher before undertaking the upgrade, you may need to speak to your IT support team.

The Sage X3 MTD submission module (standalone solution) was originally implemented to work with Sage X3 versions V6, V7 and V8, however as these versions are now outside Sage’s Lifecycle Policy they are no longer supported and have not been fully tested by Sage.

We are aware HMRC have been blocking submissions from older operating systems and this is increasing in frequency, with older CBC Cipher suites being blocked from 07 May 2024.

To remain fully compliant we recommend Customers moving to the latest version of Sage X3, Release 2024 R1.

If you have any questions, please reach out to your support contact within X3 Consulting who will be able to assist you further.

Or contact support here.